Dimensional Print Studio

KautzCraft

Tiertime has indicated they use OpenGL 2.0 to display UPStudio3. The problem is my Intel NUC with UHD graphic drivers does not (now) recognize OpenGL 2.0.  Just versions 3.0 and above.

The UPStudio3 program opens a white screen window with border, but contains no content. A second window called WAND also opens and is totally blank.

I have a search tool called OpenGL Extensions Viewer 6.3 for windows 10. It positively indicates it finds all OpenGL versions in my Intel NUC, EXCEPT 2.0

No idea why Intel would drop OpenGL 2.0 from their embedded drivers. However the Version 2.0 is over 18 years old.

Only a few Intel processors seem to be affected. Mine is a 6 core, 12 thread with the integrated UHD graphics. The condition has many reports on the internet but is very rare. User forums are terrible places to gather facts and cures.

Perhaps OpenGL 2.0 was dropped due to lack data storage space in the CPU/GPU eprom. The NUC could run UPStudio3 in the past. I reverted back to the previous graphic driver but UPStudio3 would still not display. The OpenGL2 seems to be lost forever.

My Intel NUC is therefore useless for running UPStudio3. But it also affects UPStudio2 with its Material Editing Page which is also now a blank window.

The NUC runs all other applications with no problem. I assume all other apps I have that may have OpenGL drivers are at level 3.0 and above.

These kinds of “little details” are never discussed and become mysteries for those who are affected. Intel could be thinking… anyone with a high power CPU/GPU will seldom run applications with OpenGL 2.0 as it is 18 years old. So if we drop it out, no or very few users will affected.

Tiertime should also move up from 2.0, but I have no idea what that may require for their programmers. I do believe using 18 year old software is not a good business or product plan.

Perhaps it is expected driver versions should work forever and always be supported by every GPU. 

From what I have read, when OpenGL is upgraded, the upgrade is only the new features. In other words, each level stands alone. Level 3 does not include level 1 or 2. It may offer improvements  for something in an older version but will not within itself support the old code.

So, a driver using code from version 2 may not operate if only version 3 is available. This is what I see with my NUC.

Blame?  I am not looking for blame.  I just want stuff to work. Programming with 18 year old code is not good. Neither is dropping the old code out of hardware that may need to make use of it. 

Writing updates that REQUIRE former “Legacy” version to be present so old applications keep operating, may reduce file size for the new release, but requires ever increasing storage space in the hardware that must support applications for 20 or more years.

So when OpenGL 5.0 is released, does OpenGL 3.0 get removed to make space for the update? I see no admission of this, but it looks that way to me.

Adios, OpenGL 2.0… 3.0… 3.1… 3.2… 

Serious Fire Hazard!

 IMG 1112

I own a Tiertime Cetus MK3 3D printer with the heated build plate option. I have had a long and complex history of trying to be safe in use of the heated print surface. Several years. See Previous History LINKS listed at bottom

This is the THIRD time I have experienced cable failure with the inadequate current carrying capacity of the thin “ribbon” cable and equally inadequate  cable connector pins used in this system. 

Third time is the charm. I am not going to repair and replace these components again. Tiertime has supplied replacements for the first two failures, but parts are always the same as original.

The last repair has lasted for almost a year. But just now and again, the cable burst into a cloud of acrid smoke and almost flames. Wires were red hot.

I am not interested in risking home and possible life with this non-deniable  FIRE HAZARD with this inadequate design. I was just starting a new print so I was able to immediately react to the smoke and smell. Only a few seconds and the picture clearly displays the issue.

The cable and connectors at both ends are damaged from the over current electrical flow. Heat bed, cable, and column “accessory” PCB are damaged.

I am warning any readers of this article and owners of Tiertime Cetus with heated beds to immediately cease using the heated bed. Please remove the power ribbon cable between printer body and bed. Save home and maybe life. IT IS THAT SERIOUS.

Previous History

https://dimensionalprint.kautzcraft.studio/general-topics/37-big-mama-cetus-in-heat-again

https://dimensionalprint.kautzcraft.studio/fdm-fused-deposition-modeling/31-tiertime-cetus-mk3-fail

https://dimensionalprint.kautzcraft.studio/general-topics/35-holy-smokes

IMG 0969 2I love the prints my Geeetech A20 printers make. I don’t exactly love the printers. I have an A20M (2 color) and an A20T (3 color). Owning both indicates I don’t actually hate them. They are just hard to live with…

The A20M was first. The original mixing extruder hot end had a design flaw. There were two very tiny multi orifice plates in the melted plastic flow path. One for each filament. I assume they were an attempt to mix colors when extruding. What they actually did was constantly plug up.

I ordered a new hot end from China when I discover a new improved A20M hot end was available without the tiny multi orifice plates. But delivery was going to be over a month.

So I purchased the A20T which uses a totally different hot end. Duh! Of course it is different, it has three feeds. But the overall extruder design is totally different and no orifice plates.

Both printers use the same design filament stepper drive. Geeetech calls it the Titian. Borden tubes and remote drives are unavoidable in most single nozzle extruders. No room on the hot end for multiple motor drives.

The Titian has a geared-down drive system to improve feed torque. Don’t know how really necessary that might be, but they like to brag about it.

All five of my drives have worked well for several years and hundreds of prints. 

But I have now discovered a design weakness. The tiny idler wheel that presses the filament (under spring pressure) against the toothed drive wheel has a very tiny ball bearing. The wheel itself is mounted almost totally enclosed in its mount (see first picture) 

titianIn two of my Titian drives, one on each printer, this bearing has seized and the pressure wheel is frozen solid with no rotation. When it fails, weird squeaking and clicking sounds emanate from the drives when trying to feed and the gear quickly grinds a notch in the filament and flow stops.

The first drive (A20M), I got the axel screw out but the bearing and its microscopic balls just fell apart all over my work space (picture 2). With the A20T drive arm, the axel screw will not come out and the wheel is totally locked into the arm and doesn’t rotate. The A20T arm is the one on the box in picture 1.

There has been a small design change in the pressure arm. The Titian drive taken off the A20M has a clearance slot in the arm to let filament “dust” escape. The  arm from the A20T Titian does not have the slot. It was packed with debris. No idea which is the “current” design until my new parts are received. I have five Titan repair kits on order @ $20 ea.

The drives have operated for more than a year with no issues. I do think the tiny ball bearing is inadequate for the task. Certainly not designed and rated to take the spring pressure loads. The bearings are sealed and inaccessible, so no way to lubricate. Certainly a design flaw in bearing choice. Yearly bearing changeout should not be necessary.

I have had no such problem with my five other FDM printer filament drives.

I may get another year or two from the A20’s. Then it’s EOL* for them.

*End Of Life

IMG 0891I have discovered what I think many 3D print people call a “plugged nozzle” may not be that problem at all. At least not plugged by debris.

The heat transfer within an FDM extruder is critical to good performance. The faster the feed (more filament volume) the more critical the heat flow within the extruder becomes.

The problem is any air gap in the flow path from the heating element to the extruder nozzle. Conductive heat cannot jump gaps such as screw threads. It converts to radiated heat to span the gap then back to conductive. The gap does not have to be large, The effect is like a huge resistor in electrical flow. Perhaps more like a spark gap.

If one has ever assembled a heat sink onto a CPU or any other critical heat transfer requirement, you know a “thermal paste” is required to ensure an absolute intimate connection and flow path for conductive heat.

Yet, this is never factory applied in our critical heat flow extruder connections. Probably because off the high temperatures of 250C and higher

I have been applying high heat anti-seize compound to the threaded barrel, between the heating element, thermal mass block, and the threaded feed barrel. I have not applied any to the nozzle threads for fear of introducing foreign material into the nozzle. 

Electronic CPU heat sink compound is only good to 200C., Not suitable for this use. I bought Locktite LB8009 anti-seize. Used on automotive exhaust threaded components. Not really a thermal paste but permits extremely tight no-gap screw-in assembly without seizing. Use sparingly as there is some volatile off-gassing (smoke/odor) of the low-temp base carrier material on first heat. Good to 1350C so the high-temp material is not affected by extruder heat.

The improvement to extruder performance with tight threading has cured 99% of the flow issues with my extruders. Nozzles now never “plug-up”. They actually wear down the tips after many months of continuous fault-free performance. It works for me.

For many operators (people), poor nozzle flow appears to be a plugged nozzle. So the nozzle is changed. In changing the nozzle the threaded connections are disturbed and everything “tightened up” a bit solving the heat transfer problem (for a while).  Thus, it appears it was a plugged nozzle issue.

Some folks raise print temperatures trying to improve flow. Sometimes to the point when the filament breaks down, gasses (cooks) off (thought to be proof of water) and actually burns on the nozzle, Result is an actual debris plug. 

Improve the thermal conductive path of the extruder. Every assembled component needs to have high temperature compound to eliminate every possible air gap, no matter how small. 

I greatly improved the performance of my extruders. Conductive thread compound should be an industry standard with 3D print extruders the same as heat sinks on CPU’s.

Search “High Temperature Heat Transfer Compound” for other brands. There may be something other than the high temp anti-seize I use, Must be suitable for temperatures 300C and above.

What next?

IMG 0814I have a love/hate relationship with my Tiertime Cetus 3D printers. I love how they print. Excellent linear bearings for X, Y and Z axis. My best-looking prints have come off a Cetus printer. What I hate the most is the lack of any type of manual bed leveling.

The printing plan with Cetus is to build a level RAFT for every print. That consumes a good bit of filament and time. I can live with the filament use. All creative crafts have some sort of waste factor. Only a worry when I am near the end of a spool. The time required is irritating.

The most dislike is the surface finish of the model base contacting the raft. Not possible to obtain that glass smooth finish as can be obtained printing off a level glass build plate.

The Cetus IS a minimalist 3D printer so there are compromises in design. The irony is that Cetus produces an outstanding print quality except for the base surface. There is the Love/Hate.

I can run Simplify3D sliced prints with Cetus. The original UP Studio slicer produces dependable prints but user control is very limited. The new Version 3 will be a great improvement and has worked well. But it is not ready for prime time.

Currently my WIN10 OS computer has developed a fault that will not open version 3 and also blocks material editing in version 2. UP Studio (any version) is not a Type accepted application to the WIN10 OS so there is no (apparent) co-operation in keeping system “hooks” and drivers working together. Meaning a WIN10 system upgrade can possibly “break” UP Studio functions. This seems the case for me.

I have loaded UP Studio on a “Surface” PC running fully updated WIN10 and UP Studio functions with no issues. I am stumped at what is different between The two hardware platforms running the same software.

Copyright © TEDatum Publishing . All Rights Reserved.